summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b3f7817..3994bcd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,7 +22,7 @@ pkgname=(
)
_basever=1.44
pkgver=${_basever}.0
-pkgrel=1
+pkgrel=1.2
pkgdesc="Network connection manager and user applications"
pkgdesc+=", modified for openrc"
url="https://networkmanager.dev/"
@@ -109,6 +109,10 @@ build() {
-D qt=false
)
+ # NM uses malloc_usable_size in code copied from systemd
+ CFLAGS="${CFLAGS/_FORTIFY_SOURCE=3/_FORTIFY_SOURCE=2}"
+ CXXFLAGS="${CXXFLAGS/_FORTIFY_SOURCE=3/_FORTIFY_SOURCE=2}"
+
arch-meson ${_altname}-${pkgver} build "${meson_options[@]}"
meson compile -C build ${MAKEFLAGS}
}