summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1517807..0af4444 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,17 @@
# # I maintain this because:
# Arch version lacks additional optimization and hardening flags
+# Arch version is rawgit and not a regular release
+# Arch version no longer works with mygui 3.4.1+
pkgname=openmw
pkgver=0.46.0
-pkgrel=9
+pkgrel=10
pkgdesc="Open-source engine reimplementation for the role-playing game Morrowind"
arch=('x86_64')
url="http://www.openmw.org"
license=('GPL3' 'MIT' 'custom')
-depends=('openal' 'openscenegraph' 'mygui' 'bullet' 'qt5-base' 'ffmpeg' 'sdl2' 'unshield' 'libxt' 'libvdpau')
+depends=('openal' 'openscenegraph' 'mygui-3.4.0' 'bullet' 'qt5-base' 'ffmpeg' 'sdl2' 'unshield' 'libxt' 'libvdpau')
makedepends=('cmake' 'boost' 'doxygen' 'ninja')
source=("https://github.com/OpenMW/openmw/archive/openmw-${pkgver}.tar.gz"
"openmw-0.46.0-missing-include.patch"
@@ -29,6 +31,9 @@ prepare() {
build() {
cd ${pkgname}-${pkgname}-${pkgver}
+
+ export MAKEFLAGS="-j1"
+
# gcc 10.2 + qt 5.15 + pie = segfault
export CFLAGS="$CFLAGS -O3 -flto=auto"
export CXXFLAGS="$CXXFLAGS -O3 -flto=auto"