summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjc_gargma <jc_gargma@iserlohn-fortress.net>2019-09-03 15:31:36 -0700
committerjc_gargma <jc_gargma@iserlohn-fortress.net>2019-09-03 15:31:36 -0700
commitff928c797dc262db42c3444399c282442dfa55ba (patch)
tree51cf7bc37f87d790407c084a9c26a1a9082cf58d /PKGBUILD
parentUpdated to 28.7.0 (diff)
downloadpalemoon-ff928c797dc262db42c3444399c282442dfa55ba.tar.xz
Enabled -fPIC and -O3
Disbale elf-hack, strip, and strip-install. The compiler can do these jobs.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3d640db..867a7a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,7 +29,7 @@ source=(palemoon-$pkgver.tar.gz::https://github.com/MoonchildProductions/UXP/arc
mozconfig.in
system-libs.patch)
sha256sums=('c7fd6cbac161957bbca1c861cada556dd853e368cc2122e9a5f1052e72fc659e'
- '54e0f2b3e87785d03b782b597bfaceb7607828e4fc44caf82e72bd98241274c6'
+ '7e5ee322ac8f35fbed37fc8fcde126e93a1fe4aed5cb4b6cdee2f5c08d85c81a'
'20a037116f85737849b663c61b55fdc7120f83e960ba5b416d70a910de0e9443')
prepare() {
@@ -46,8 +46,8 @@ build() {
export MOZBUILD_STATE_PATH="$srcdir/mozbuild"
export MOZCONFIG="$srcdir/mozconfig"
- export CFLAGS="$CFLAGS -fstack-protector-all -flto=4"
- export CXXFLAGS="$CXXFLAGS -fstack-protector-all -flto=4"
+ export CFLAGS="$CFLAGS -fPIC -fstack-protector-all -flto=4 -O3"
+ export CXXFLAGS="$CXXFLAGS -fPIC -fstack-protector-all -flto=4 -O3"
export LDFLAGS="$LDFLAGS,-fuse-ld=gold"
python2 mach build
}