summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 15 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 94f27d3..c898981 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,6 +3,8 @@
# Contributor (AUR): artiom <a.mv at gmx dot fr>
# Contributor (AUR): ilikenwf
# Contributor (AUR): American_Jesus
+# Contributor (AUR): Mufflone
+# Contributor (AUR): switchnode
# # I maintain this because:
# AUR version does not use full length commit IDs
@@ -14,23 +16,21 @@ pkgname=palemoon
_pmaltname=pale-moon
_pmotheraltname=Pale-Moon
_uxpaltname=uxp
-pkgver=33.1.0
+pkgver=33.2.1
pkgrel=1
# palemoon commit ID can be found at https://repo.palemoon.org/MoonchildProductions/Pale-Moon/tags
-_commit=1d5a6adf5f1e970041aad0b227cbc9f1cfe2ca72
+_commit=e1afd4fc47a620ed1eb12b6b01bc1ddcf5f8866c
# UXP commit ID can be found at https://repo.palemoon.org/MoonchildProductions/UXP/tags
-_UXPcommit=55b33fb02b9e4715c1db03591bd44b25c5a0d9dd
+_UXPcommit=11fc818dfbb1c20f431ef28ad96e0e0e4dd073ac
pkgdesc="Open source web browser based on Firefox focusing on efficiency."
arch=(x86_64 i686)
-license=(MPL GPL LGPL)
+license=(MPL-2.0 GPL LGPL)
url="https://www.palemoon.org/"
options=(lto)
-depends=(gtk3 gtk2 desktop-file-utils libxt startup-notification mime-types dbus-glib
- libpulse alsa-lib
+depends=(gtk2 dbus-glib desktop-file-utils libxt mime-types alsa-lib
+ startup-notification
bzip2 libffi libjpeg-turbo pixman zlib)
-makedepends=(unzip zip python2 yasm
- jack
- autoconf2.13
+makedepends=(python2 unzip zip yasm libpulse jack
git)
optdepends=('ffmpeg: various video and audio support'
'alsa-utils: ALSA support'
@@ -45,13 +45,13 @@ source=(git+"https://repo.palemoon.org/MoonchildProductions/${_pmotheraltname}?s
mozconfig.in)
sha1sums=('SKIP'
'SKIP'
- 'c2dda3fd9ef3d84546c18046833fbabee9f5aa6d')
+ '71ad1fdd6f76c896486565d0dfa27b0919228b00')
sha256sums=('SKIP'
'SKIP'
- 'fe73fb860b7cbd1153a4322811aefef09b87f609f41840269d9480530a0db57d')
+ '2da2111c9c204a4babaf19e1e1c1d629513b410d1290ac44a1f14c02a4f5d704')
b2sums=('SKIP'
'SKIP'
- 'bbbc3d1f72bab30fa15aa2754b977efd9f0908935f0c91804ec75bf5124a818c56d1eaa5f84ca95978a4fba96e4e0edd7a395ed92c4efe81d46c480026c6712b')
+ '290dfd5c3f93025048c94b6b592a3605e093862f1c4fbd96a9cde61b91ebb53b2901ce62b646cff298f9286bd46767972ac20a7bd19d902b470f15ca4c9fa4b7')
#https://www.palemoon.org/0x8FCF9CEC.asc
validpgpkeys=('3DAD8CD107197488D2A2A0BD40481E7B8FCF9CEC')
@@ -72,13 +72,14 @@ build() {
export MOZ_MAKE_FLAGS="${MAKEFLAGS}"
#export MOZ_MAKE_FLAGS="-j32"
-# # Remove option not supported by ld.gold to prevent configure failure
-# export LDFLAGS="${LDFLAGS/-Wl,-z,pack-relative-relocs/}"
+ # Remove option not supported by ld.gold to prevent configure failure
+ export LDFLAGS="${LDFLAGS/-Wl,-z,pack-relative-relocs/}"
export MOZBUILD_STATE_PATH="${srcdir}/mozbuild"
export MOZCONFIG="${srcdir}/mozconfig"
export CFLAGS="$CFLAGS -O3 -fstack-protector-all -fPIC"
export CXXFLAGS="$CXXFLAGS -O3 -fstack-protector-all -fPIC"
+
./mach build
}