summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..d9d9c5a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: jc_gargma <jc_gargma@iserlohn-fortress.net>
+# Maintainer (AUR): Jake <aur@ja-ke.tech>
+# Contributor (AUR): Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor (AUR): Chris Giles <Chris.G.27 (at) Gmail.com>
+
+# # I maintain this because:
+# AUR version lacks additional optimization and hardening flags
+
+pkgname=q4wine
+pkgver=1.3.12
+pkgrel=1
+pkgdesc="A Qt5 GUI for Wine"
+arch=("x86_64")
+url="http://sourceforge.net/projects/${pkgname}/"
+license=("GPL3")
+depends=("qt5-base" "wine" "sqlite" "which" "icoutils")
+makedepends=("cmake" "qt5-tools" "qt5-svg")
+optdepends=("winetricks" "fuseiso")
+options=('!emptydirs')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/brezerk/q4wine/archive/v${pkgver}.tar.gz")
+b2sums=('5ef483b68decefbd6926cd4fa11d95d4b7c7698258728ff99c2f23f4e915b5ea690f3b3d9084f26c1ac0862091b4475eefb88170427cd1cc7ac6e025c2b3d2fc')
+
+build() {
+ cd "$srcdir"/${pkgname}-${pkgver/_/-}
+ export CFLAGS="$CFLAGS -O3 -fstack-protector-all -flto=4 -fPIE"
+ export CXXFLAGS="$CXXFLAGS -O3 -fstack-protector-all -flto=4 -fPIE"
+ export LDFLAGS="$LDFLAGS,-pie"
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIBS_ENTRY_PATH=/usr/lib/$pkgname \
+ -DQT5=ON \
+ .
+ make
+}
+
+package() {
+ cd "$srcdir"/${pkgname}-${pkgver/_/-}
+ make DESTDIR="$pkgdir" install
+}