summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjc_gargma <jc_gargma@iserlohn-fortress.net>2024-02-25 20:42:32 -0800
committerjc_gargma <jc_gargma@iserlohn-fortress.net>2024-02-25 20:42:32 -0800
commit5bcbae01e8671e89643ac62da6c89c32607a9b68 (patch)
tree518e7a6f3e07790b811c7415600a87f913da0403 /PKGBUILD
parentRebuild with hotfixes. (diff)
downloadtmux-5bcbae01e8671e89643ac62da6c89c32607a9b68.tar.xz
Updated to 3.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 9 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 47c7757..77aaf7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,33 +5,22 @@
# AUR version lacks additional optimization and hardening flags
pkgname=tmux
-pkgver=3.3_a
-pkgrel=7
+pkgver=3.4
+pkgrel=4
pkgdesc='Terminal multiplexer'
url='https://github.com/tmux/tmux/wiki'
arch=('x86_64')
license=('BSD')
-depends=('ncurses' 'libevent' 'libutempter')
+depends=('libevent' 'libevent_core-2.1.so'
+ 'libutempter'
+ 'ncurses' 'libncursesw.so')
# # For some reason this breaks compiling. "error: C compiler cannot create executables"
# # But old-fashioned raw injection of -flto=auto via export doesn't.
#options=('lto')
-source=("https://github.com/tmux/tmux/releases/download/${pkgver/_/}/tmux-${pkgver/_/}.tar.gz"
- '0001-CVE-2022-47016.patch'
- '0002-ncurses.patch')
-sha256sums=('e4fd347843bd0772c4f48d6dde625b0b109b7a380ff15db21e97c11a4dcdf93f'
- '58fb690833e086b71b52555aa8eced695ace0a0bc51b8bccfda441e35a47ca93'
- '70e8cc2a95dd4a19ff54bcf0abaeff6464ebecbaace5ed0aec06ca93a84d415a')
-b2sums=('e835ce0f136175521035a684419f221864edb0a9506d7d68cbc0239b1349e78949ebd96573a9d8651a2df6d99acb433075d6e0c20d7394a53fe6b44bd9e56069'
- '5d6e44167fc067da71a7b222eea9f631bf9a64e88846d243207e9e29ab25e0bc78addca6b006ceed43a45be88abc53822a1250fd5b9a7c4830496ef77408eae3'
- '6077460e424e4857eea3bf36d88a400155d95481500b25005790f3de782b8e7f2790c3ba450f6704149f236562fb25b743575c0e73cbc3cbec7785aa729816c3')
-
-prepare() {
- cd "$pkgname-${pkgver/_/}"
- patch -Np1 -i ../0001-CVE-2022-47016.patch
- patch -Np1 -i ../0002-ncurses.patch
+source=("https://github.com/tmux/tmux/releases/download/${pkgver/_/}/tmux-${pkgver/_/}.tar.gz")
+sha256sums=('551ab8dea0bf505c0ad6b7bb35ef567cdde0ccb84357df142c254f35a23e19aa')
+b2sums=('2b1990b95d7439702e9287402d9828d4ecab573202c099aa482969c047b540d4b899f79d87587fc712e727d9cebf5fa7393512087e469fc355b4a30b1894e229')
- autoreconf -fi
-}
build() {
cd "$pkgname-${pkgver/_/}"
@@ -42,6 +31,7 @@ build() {
./configure \
--prefix=/usr \
+ --enable-sixel \
--enable-utempter
make
}