summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fe8a6b5..94f4236 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@
pkgname=tome4
pkgver=1.7.4
-pkgrel=1
+pkgrel=1.2
_offlinever=1.7
_ashesver=1.1.4
_orcsver=1.1.10
@@ -24,7 +24,7 @@ url="https://te4.org/"
license=('custom' 'GPL3')
depends=(glu openal libvorbis sdl2_ttf sdl2_image)
makedepends=(premake zip unzip)
-options=(emptydirs !makeflags)
+options=(emptydirs !makeflags !lto)
source=("${url}dl/t-engine/t-engine4-src-${pkgver}.tar.bz2"
ashes-urhrok_${_ashesver}.teaac
orcs_${_orcsver}.teaac
@@ -69,11 +69,14 @@ build() {
cd t-engine4-src-${pkgver}
premake5 gmake
- # higher than -j1 or -flto=1 breaks compiling
- export CFLAGS="$CFLAGS -O3 -fstack-protector-all -flto=1 -fPIE"
- export CXXFLAGS="$CXXFLAGS -O3 -fstack-protector-all -flto=1 -fPIE"
- export LDFLAGS="$LDFLAGS,-pie"
- make config=release
+
+ # higher than -flto=1 breaks compiling
+ export CFLAGS="$CFLAGS -O3 -fstack-protector-all -flto=1 -fPIE"
+ export CXXFLAGS="$CXXFLAGS -O3 -fstack-protector-all -flto=1 -fPIE"
+ export LDFLAGS="$LDFLAGS,-pie"
+
+ # higher than -j1 breaks compiling
+ make config=release -j1
}
###############################################################################