summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 7 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 97c2000..b2f2ceb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,25 +9,23 @@
pkgname=uboot-pinebookpro
pkgver=2020.01
-pkgrel=4
+pkgrel=6
pkgdesc="U-Boot for Pinebook Pro"
arch=('aarch64')
#arch=('x86_64')
url='https://git.eno.space/pbp-uboot'
license=('GPL')
-backup=('boot/boot.txt' 'boot/boot.scr')
-depends=('uboot-tools')
+backup=('boot/extlinux/extlinux.conf')
makedepends=('arm-none-eabi-gcc' 'bc' 'dtc' 'git' 'python')
install=${pkgname}.install
_commit_atf=22d12c4148c373932a7a81e5d1c59a767e143ac2
source=("git+https://git.eno.space/pbp-uboot.git"
"git+https://github.com/ARM-software/arm-trusted-firmware.git#commit=$_commit_atf"
- 'boot.txt'
- 'mkscr')
+ 'extlinux.conf')
+ #'0001-nvme-support.patch')
b2sums=('SKIP'
'SKIP'
- 'cf03a62fd803187ab91db0942a5d7f835ffcf75c3b0b6ab8ca8c3e8a6762b328339580f3a80eeb1569bf4bca87a9cd60a83c3713338af2de4244717177c8d363'
- '4ea782264696aa85e30847413088bd338e2beb2ec4e57c2808f80af28ac613ab4ae82b37eb0ff902e66f8a12082a1f9a546bbf20dfeb4c43f59f465987043ede')
+ 'cf9a1e25f45de93fff23e015b92c0d8386ef0397643d9122e7a1a0560ed1531c66be1567399af71b1063841253a0a54367e821fb2a3273c91c65ac61b3dfe44d')
build() {
cd arm-trusted-firmware
@@ -43,8 +41,7 @@ build() {
package() {
cd pbp-uboot
- mkdir -p "${pkgdir}/boot"
+ mkdir -p "${pkgdir}/boot/extlinux"
cp idbloader.img u-boot.itb "${pkgdir}/boot"
- mkimage -A arm -O linux -T script -C none -n "U-Boot boot script" -d ${srcdir}/boot.txt "${pkgdir}/boot/boot.scr"
- cp ${srcdir}/{boot.txt,mkscr} "${pkgdir}"/boot
+ cp "${srcdir}"/extlinux.conf "${pkgdir}"/boot/extlinux
}