summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjc_gargma <jc_gargma@iserlohn-fortress.net>2017-05-24 13:46:36 -0700
committerjc_gargma <jc_gargma@iserlohn-fortress.net>2017-05-24 13:46:36 -0700
commit18ff842f2ba46f2a51b067f4b750cc9be2b2793f (patch)
tree5888bf76ebc1f2a6508f02e115e709fcb234d825 /PKGBUILD
downloadyour-freedom-18ff842f2ba46f2a51b067f4b750cc9be2b2793f.tar.xz
Initial Commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..970cd4f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+
+pkgname=your-freedom
+pkgdesc="This package conflicts with every proven nonfree package to ensure your system is free."
+license=('GPL3')
+url="https://git.parabola.nu/blacklist.git"
+pkgver=20170524
+pkgrel=1
+
+arch=('any')
+groups=('base' 'base-openrc')
+install=${pkgname}.install
+
+makedepends=(librelib)
+source=(blacklist.txt)
+sha512sums=('fc8e4ef6e5601b45a16cfe87b6f074edbc859f9f126536f235bded3d470c9fc7e2f27bd0d24fb27699c655f888e25dcac1c7c83a4a3fcd6b36cacab36f857d03')
+
+package() {
+ cd "$srcdir"
+
+ conflicts=($(
+ < blacklist.txt \
+ libreblacklist normalize |
+ cut -d: -f1,2 |
+ sed -n 's/:$//p' |
+ sort -u
+ ))
+
+ install -Dm644 blacklist.txt "$pkgdir"/usr/share/doc/${pkgname}/blacklist.txt
+}