summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjc_gargma <jc_gargma@iserlohn-fortress.net>2022-04-21 15:58:32 -0700
committerjc_gargma <jc_gargma@iserlohn-fortress.net>2022-04-21 15:58:32 -0700
commitb34976e29004248d9d6eb8b7ed483004aaf3e4f6 (patch)
tree29eaee07fb3daad773794aadc8bcf4754b21b201 /PKGBUILD
parentRebuild for python 3.10 and boost 1.78 (diff)
download0ad-b34976e29004248d9d6eb8b7ed483004aaf3e4f6.tar.xz
Rebuild with glibc 2.35 patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8a50435..03881b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
pkgname=0ad
pkgver=a25.b
_pkgver=0.0.25b-alpha
-pkgrel=3
+pkgrel=4
pkgdesc="Cross-platform, 3D and historically-based real-time strategy game"
arch=('x86_64')
url="https://play0ad.com/"
@@ -17,14 +17,22 @@ license=('GPL2' 'CCPL')
depends=('0ad-data' 'binutils' 'boost-libs' 'curl' 'enet' 'libogg' 'libpng' 'libvorbis'
'libxml2' 'openal' 'sdl2' 'wxgtk3' 'zlib' 'libgl' 'glu' 'fmt'
'gloox' 'miniupnpc' 'libminiupnpc.so' 'icu' 'nspr' 'libsodium')
-makedepends=('boost' 'cmake' 'mesa' 'zip' 'libsm' 'rust')
+makedepends=('boost' 'cmake' 'mesa' 'zip' 'libsm' 'rust' 'python')
+options=('!lto') # breaks spidermonkey linking (https://bugs.gentoo.org/746947)
source=("https://releases.wildfiregames.com/$pkgname-$_pkgver-unix-build.tar.xz"
+ "glibc-2.35.patch"
"python-3.10.patch")
+sha512sums=('e8069897b97b381099ab5ec5868d27e96c699105b3307054d1bc7bf9236a537f02625ba9034892d91f3e951b4f95c9ce5fb75ed0a7c14b8a294882482fd9c1b4'
+ 'e56fa4a3a43f7510dde50d5fd0ccda2f935d9ad2aac44d9af9e89109c655b605f8ef582e1188be3dc1d42b7feef0caefa0ec514776696603c237f054fd6778c9'
+ '42df5eb7c4a99b31365b7f15c5bcd76c978339f2837eb8bc6ec371979429d0f0a6e31e870f6851aa40fc4859cb3e82f74821a01d04b82b486342db0fa60bf55e')
b2sums=('674d69d625137709a186f9273607dc353fc99aea68ef3f2ea5031dbe2f684176910d757c3f03c7fbdac475d30708be448b71f5020d27a65c346bf147223bcb9d'
+ 'e7d372e68b450f98631239ab0bb0c9eafdedb48f8a788037ce60851f28258a962a31a22afe80968bc1d706017acf7e9b25821fbe282db889ef534670b6954c89'
'6b6853eacbeadfe7e95382c97572c60b1838d5f4b0b925c2bb977be76db6a0a2ac97376089a42fca6a7956319b69c56ec0d2fb59a1114002d708486582de346d')
prepare() {
- patch -d $pkgname-$_pkgver -p1 < python-3.10.patch # Fix spidermonkey build with Python 3.10
+ cd $pkgname-$_pkgver
+ patch -Np1 -i ../glibc-2.35.patch # https://code.wildfiregames.com/rP26536
+ patch -Np1 -i ../python-3.10.patch # Fix spidermonkey build with Python 3.10
}
build() {