summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjc_gargma <jc_gargma@iserlohn-fortress.net>2024-02-05 00:31:00 -0800
committerjc_gargma <jc_gargma@iserlohn-fortress.net>2024-02-05 00:31:00 -0800
commit66f90ae6df2e7138eefcad2a357c9e09d34027af (patch)
tree1b1773ed81243c187e0743826f13672883e55d1a /PKGBUILD
parentApply hotfixes. (diff)
downloadcataclysm-bn-66f90ae6df2e7138eefcad2a357c9e09d34027af.tar.xz
Add hotfixes:
-Fix player being given a wakeup from noise notice when it happens to npcs --also reduces npc 'move please' chat spam when following the player -Fix card readers not despawning riot turrets -Fix npcs detecting explosives using psychic powers
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 18 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 098d590..796c4ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,7 +18,7 @@ _pkgname=Cataclysm-BN
pkgver=0.5.2
#pkgver=202310040030
#_pkgver=2023-10-04-0030
-pkgrel=5
+pkgrel=6
pkgdesc="A post-apocalyptic roguelike."
#url="http://cataclysmrl.blogspot.com/"
#url="http://www.cataclysm.glyphgryph.com/"
@@ -64,6 +64,9 @@ source=("$pkgname-$pkgver.tar.gz::https://github.com/cataclysmbnteam/Cataclysm-B
"hotfix-03_fix-Fix-overlapping-text-in-look-around.-4156.patch"
"hotfix-04_fix-uaf-in-safe-references-4165.patch"
"hotfix-05_feat-balance-closed-glass-windows-block-scent-4114.patch"
+ "hotfix-06_fix-two-cases-of-NPCs-printing-messages-in-odd-conte.patch"
+ "hotfix-07_fix-allow-card-readers-to-despawn-riot-turrets-too-4.patch"
+ "hotfix-09_fix-NPCs-no-longer-magically-aware-of-explosives-the.patch"
"ammo-10_ammo-order-fix.patch"
"ammo-11_fix-volume-40mm.patch"
@@ -189,6 +192,9 @@ b2sums=('9daaba287ef99aa3b33b6f3fbb129b97a2b4dcc265dd7affa08ccee1bdd41b4568e061a
'29bc7e4f9ca7437930a43455be8d1166ff2b7bbaaa58209692d4a15fa7c4b19a4b185881d9a1c5abafe363de31f31fe44585da24dbeecaba183e884539443228'
'af8d397d3b42ec0ff461337c19e470dd05b367a362cff092dbe6083841fee062cf899799e69db11fba05179775ac398f8ef3bf79a9f0e25b8774350451e73363'
'b388513e6e2d67b3c6ae4f7c27d59bcd78fac9909e887fa4c58932052c0f3355b1dad23abfe404ca2bec82e278759e5be5982abb8b5b1dc7c908c51f7a510d05'
+ '8dd1ade1242764bb7b69bf3b564f4e0ad7a2a53e4153a421f2b901c811daa038508e6eae21cd25d48f1c685024229a286e57f9357a04608332b3c8de1cb904e2'
+ 'f6a8421d0aaf32e1062ce9b90b4a699b66374ddd6a3f7bd1705b476d2e74c627f594b99006c6f88389c444f7ed3a5d87fc2b323b2331c4221706120d6eb52abb'
+ 'c1cdb13cf76e0f3b879c463258701a8ef268097323f6befcda1a1027be19256daf38ad4d80d982347e36570a5df4339a3020159b7498a997e0e26998fdaa564d'
'df26a597afe46a35e07f02c32839e2f7f57cf4d4d9bf0e62eb645d1b720f601fe2e9787462a0ab0ba8b788c727b846272a4ca6ecf81f96bb058d070b53633dcc'
'ba2964e64df20167c722e71951db28d039e637397a6be2e7f5312da10ab3c57a1982ec1ae1c37dd361317292b8c519f678472eb06360d4368294e0b636704c15'
'365e1ac9f9ee636f2578f6fd8ab16b6460894cb9b76cf0aee5d8a55f42d882d6ee0b04e80194f4c346bfdb0778e11e30b8c03541b4d351602ccfd63cee7e3cf0'
@@ -312,12 +318,22 @@ prepare() {
# Fix overlapping text when looking around
patch -Np1 --no-backup-if-mismatch -i "$srcdir"/hotfix-03_fix-Fix-overlapping-text-in-look-around.-4156.patch
- # Fix safe reference error on save and quit
+ # Fix safe reference error on throwing explosives. fix for error on save and quit still MIA.
patch -Np1 --no-backup-if-mismatch -i "$srcdir"/hotfix-04_fix-uaf-in-safe-references-4165.patch
# Fix zombies having a psychic sense of smell
patch -Np1 --no-backup-if-mismatch -i "$srcdir"/hotfix-05_feat-balance-closed-glass-windows-block-scent-4114.patch
+ # Fix player being given a wakeup from noise notice when it happens to npcs
+ # also reduces npc 'move please' chat spam when following the player
+ patch -Np1 --no-backup-if-mismatch -i "$srcdir"/hotfix-06_fix-two-cases-of-NPCs-printing-messages-in-odd-conte.patch
+
+ # Fix card readers not despawning riot turrets
+ patch -Np1 --no-backup-if-mismatch -i "$srcdir"/hotfix-07_fix-allow-card-readers-to-despawn-riot-turrets-too-4.patch
+
+ # Fix npcs detecting explosives using psychic powers
+ patch -Np1 --no-backup-if-mismatch -i "$srcdir"/hotfix-09_fix-NPCs-no-longer-magically-aware-of-explosives-the.patch
+
# # Adjust default mods
patch -Np1 --no-backup-if-mismatch -i "$srcdir"/src-20_fix-default-mods.patch