summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorjc_gargma <jc_gargma@iserlohn-fortress.net>2018-06-27 01:10:18 -0700
committerjc_gargma <jc_gargma@iserlohn-fortress.net>2018-06-27 01:10:18 -0700
commitfec02743b8951d9d80fbe766146316da34a266fb (patch)
treec32e36342b218285cdaaa5a0203f22aed738e376 /PKGBUILD
parentUpdated to 60.0.2 | Switched to alsa | Updated vendor.js (diff)
downloadfirefox-esr-fec02743b8951d9d80fbe766146316da34a266fb.tar.xz
Updated to 61.0 | Added patch to remove all system addons
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD68
1 files changed, 29 insertions, 39 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 45d9307..4b55ded 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,50 +4,36 @@
# Contributor: Jakub Schmidtke <sjakub@gmail.com>
pkgname=firefox
-pkgver=60.0.2
+pkgver=61.0
pkgrel=1
pkgdesc="Standalone web browser from mozilla.org"
arch=(x86_64)
license=(MPL GPL LGPL)
url="https://www.mozilla.org/firefox/"
depends=(gtk3 mozilla-common libxt startup-notification mime-types dbus-glib ffmpeg
- nss hunspell sqlite ttf-font alsa-lib libvpx icu)
+ nss hunspell-en_CA sqlite ttf-font alsa-lib libvpx icu)
makedepends=(unzip zip diffutils python2 yasm mesa imake gconf inetutils xorg-server-xvfb
- autoconf2.13 rust mercurial clang llvm gtk2)
+ autoconf2.13 rust mercurial clang llvm gtk2 python)
optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration'
'speech-dispatcher: Text-to-Speech')
options=(!emptydirs !makeflags !strip)
_repo=https://hg.mozilla.org/mozilla-unified
source=("hg+$_repo#tag=FIREFOX_${pkgver//./_}_RELEASE"
- complete-csd-window-offset-mozilla-1457691.patch.xz
- 0001-Bug-1435212-Add-support-for-FFmpeg-4.0.-r-bryce.patch.xz
$pkgname.desktop firefox-symbolic.svg
- no-crmf.diff
- vendor.js)
+ vendor.js
+ package-manifest.diff)
sha256sums=('SKIP'
- 'a3fb3c3b6fb775c99afdbad507848b77c5e4bbaac2e8ceeb1bfb47699c4b6268'
- '8422030440032535d918844263fbd92d39bff207acb5fff55ed0afee38bcf582'
'677e1bde4c6b3cff114345c211805c7c43085038ca0505718a11e96432e9811a'
'9a1a572dc88014882d54ba2d3079a1cf5b28fa03c5976ed2cb763c93dabbd797'
- '02000d185e647aa20ca336e595b4004bb29cdae9d8f317f90078bdcc7a36e873'
- 'db998007bbc6b00cf5079efa6b2b72302600517cf415d999aa656415709fbbff')
+ '158815b51b6a20adb943e5747e0d915018bfb421970f0b582f56498c97b11efa'
+ '28e5db73f04ce8794f68822deda5512c64f832e542ad58fb7e40cad9e4785664')
prepare() {
mkdir path
ln -s /usr/bin/python2 path/python
- cd mozilla-unified
- # https://bugzilla.mozilla.org/show_bug.cgi?id=1283299#c158
- patch -Np1 -i ../complete-csd-window-offset-mozilla-1457691.patch
-
- # https://bugzilla.mozilla.org/show_bug.cgi?id=1435212
- patch -Np1 -i ../0001-Bug-1435212-Add-support-for-FFmpeg-4.0.-r-bryce.patch
-
- # https://bugzilla.mozilla.org/show_bug.cgi?id=1371991
- patch -Np1 -i ../no-crmf.diff
-
- cat >.mozconfig <<END
+ cat >$srcdir/mozilla-unified/.mozconfig <<END
ac_add_options --enable-application=browser
ac_add_options --prefix=/usr
@@ -73,7 +59,7 @@ ac_add_options --with-system-jpeg
ac_add_options --with-system-libvpx
ac_add_options --with-system-nspr
ac_add_options --with-system-nss
-ac_add_options --enable-system-hunspell
+#ac_add_options --enable-system-hunspell
ac_add_options --enable-system-sqlite
ac_add_options --enable-system-ffi
@@ -87,27 +73,34 @@ ac_add_options --disable-tests
ac_add_options --disable-updater
ac_add_options --disable-webrtc
-mk_add_options MOZ_MAKE_FLAGS="-j2"
+mk_add_options MOZ_MAKE_FLAGS="-j4"
END
# Disable various components at the source level
- sed -i 's|[;]1|;0|' toolkit/components/telemetry/TelemetryStartup.manifest || die "failed break telemetry startup"
- sed -i 's|[;]1|;0|' browser/experiments/Experiments.manifest || die "failed to break ExperimentsService"
- sed -i '/pocket/d' browser/extensions/moz.build || die "failed to wipe pocket"
- sed -i '/activity-stream/d' browser/extensions/moz.build || die "failed to wipe activity-stream"
- sed -i '/aushelper/d' browser/extensions/moz.build || die "failed to wipe aushelper"
- sed -i '/followonsearch/d' browser/extensions/moz.build || die "failed to wipe followonsearch"
- sed -i '/formautofill/d' browser/extensions/moz.build || die "failed to wipe formautofill"
- sed -i '/onboarding/d' browser/extensions/moz.build || die "failed to wipe onboarding"
- sed -i '/screenshots/d' browser/extensions/moz.build || die "failed to wipe screenshots"
- #sed -i '/webcompat/d' browser/extensions/moz.build || die "failed to wipe webcompat"
+ sed -i 's|[;]1|;0|' $srcdir/mozilla-unified/toolkit/components/telemetry/TelemetryStartup.manifest
+# sed -i 's|[;]1|;0|' $srcdir/mozilla-unified/browser/experiments/Experiments.manifest
+ sed -i '/pocket/d' $srcdir/mozilla-unified/browser/extensions/moz.build
+ sed -i '/activity-stream/d' $srcdir/mozilla-unified/browser/extensions/moz.build
+ sed -i '/aushelper/d' $srcdir/mozilla-unified/browser/extensions/moz.build
+ sed -i '/followonsearch/d' $srcdir/mozilla-unified/browser/extensions/moz.build
+ sed -i '/formautofill/d' $srcdir/mozilla-unified/browser/extensions/moz.build
+ sed -i '/onboarding/d' $srcdir/mozilla-unified/browser/extensions/moz.build
+ sed -i '/screenshots/d' $srcdir/mozilla-unified/browser/extensions/moz.build
+ sed -i '/webcompat/d' $srcdir/mozilla-unified/browser/extensions/moz.build
+ #sed -i '/@RESPATH@\/browser\/features\/*/d' $srcdir/mmozilla-unified/browser/installer/package-manifest.in
}
build() {
cd mozilla-unified
+ mkdir $srcdir/mozilla-unified/obj-x86_64-pc-linux-gnu
+ mkdir $srcdir/mozilla-unified/obj-x86_64-pc-linux-gnu/dist
+ mkdir $srcdir/mozilla-unified/obj-x86_64-pc-linux-gnu/dist/bin
+ mkdir $srcdir/mozilla-unified/obj-x86_64-pc-linux-gnu/dist/bin/browser
+ mkdir $srcdir/mozilla-unified/obj-x86_64-pc-linux-gnu/dist/bin/browser/features
+# touch $srcdir/mozilla-unified/obj-x86_64-pc-linux-gnu/dist/bin/browser/features/blank
# _FORTIFY_SOURCE causes configure failures
CPPFLAGS+=" -O2"
@@ -124,6 +117,7 @@ build() {
package() {
cd mozilla-unified
+ patch -p0 $srcdir/mozilla-unified/browser/installer/package-manifest.in $srcdir/package-manifest.diff
DESTDIR="$pkgdir" ./mach install
# find . -name '*crashreporter-symbols-full.zip' -exec cp -fvt "$startdir" {} +
@@ -131,6 +125,7 @@ package() {
local shortver=$(echo $pkgver | cut -d'.' -f1,2)
sed -i "s/@PKGVER@/$shortver/g" "$pkgdir/usr/lib/$pkgname/browser/defaults/preferences/vendor.js"
+
_distini="$pkgdir/usr/lib/$pkgname/distribution/distribution.ini"
install -Dm644 /dev/stdin "$_distini" <<END
[Global]
@@ -158,11 +153,6 @@ END
install -Dm644 ../$pkgname.desktop \
"$pkgdir/usr/share/applications/$pkgname.desktop"
- # Use system-provided dictionaries
- rm -r "$pkgdir/usr/lib/$pkgname/dictionaries"
- ln -Ts /usr/share/hunspell "$pkgdir/usr/lib/$pkgname/dictionaries"
- ln -Ts /usr/share/hyphen "$pkgdir/usr/lib/$pkgname/hyphenation"
-
# Install a wrapper to avoid confusion about binary path
install -Dm755 /dev/stdin "$pkgdir/usr/bin/$pkgname" <<END
#!/bin/sh